System Requirements

pptXTREME 2015 Add-ins are compatible with:

NewItem36 Windows 7 | 8 (32 or 64 bit*)

NewItem37 PowerPoint 2007 | 2010 | 2013 (32 or 64 bit*)

NewItem35 Photoshop CC2014 2007 | 2010 | 2013 (32 or 64 bit*)

*NOTE: Versions must match. i.e. If you use PowerPoint 64 bit, then you must use Photoshop 64 bit with Photoshop Import

X

Your item has been successfully added to your cart!

X

This is a 30 day free trial of pptXTREME.!

Please click the button below to begin download.